.
スポンサーリンク

OpenPNE3.8.34からOpenPNE3.8.36にアップデートを試みるとmigrateでエラーが出る。

投稿ツリー


このトピックの投稿一覧へ

kondo

なし OpenPNE3.8.34からOpenPNE3.8.36にアップデートを試みるとmigrateでエラーが出る。

msg# 1.1
depth:
1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2020/6/19 18:50 | 最終変更
kondo  管理人   投稿数: 87

$ ./symfony openpne:migrate

migrateでエラーがでる。
その結果かどうか分からないが、スマフォから日記、タイムライン、メンバー等が表示されなくなる。

1 error(s) encountered during migration

 =======================================                                                                                                                       
  Error #1 - Could not find migration class for migration step: 48                                                                                             
 #0 /home/lib/vendor/symfony/lib/plugins/sfDoctrinePlugin/lib/vendor/doctrine/Doctrine/Migration.php(501): opMigration->getMigrationClass('48') 
 #1 /home/lib/migration/opMigration.class.php(109): Doctrine_Migration->_doMigrateStep('down', '48')                                            
 #2 /home/lib/vendor/symfony/lib/plugins/sfDoctrinePlugin/lib/vendor/doctrine/Doctrine/Migration.php(483): opMigration->_doMigrateStep('down', '48')
 #3 /home//lib/vendor/symfony/lib/plugins/sfDoctrinePlugin/lib/vendor/doctrine/Doctrine/Migration.php(328): Doctrine_Migration->_doMigrate(47)   
 #4 /home/lib/task/openpneMigrateTask.class.php(154): Doctrine_Migration->migrate()                                                             
 #5 /home/lib/task/openpneMigrateTask.class.php(105): openpneMigrateTask->migrateFromScript('OpenPNE', Object(sfDatabaseManager))               
 #6 /home/lib/vendor/symfony/lib/task/sfBaseTask.class.php(68): openpneMigrateTask->execute(Array, Array)                                       
 #7 /home/lib/vendor/symfony/lib/task/sfTask.class.php(97): sfBaseTask->doRun(Object(sfCommandManager), NULL)                                   
 #8 /home/lib/vendor/symfony/lib/command/sfSymfonyCommandApplication.class.php(76): sfTask->runFromCLI(Object(sfCommandManager), NULL)          
 #9 /home/lib/vendor/symfony/lib/command/cli.php(20): sfSymfonyCommandApplication->run()                                                        
 #10 /home/symfony(14): include('/home/...')                                                                                           
 #11 {main}

環境
centOS7.8
php5.6
10.4.13-MariaDB

OpenPNE公式SNSで、MariaDBに対応していないという回答があったので、mySQLに戻せば解消するのだろうか?でも戻したくないなー。

投票数:0 平均点:0.00
返信する

この投稿に返信する

題名
ゲスト名
投稿本文

  条件検索へ


検索

ページの一覧 索引

ログイン

ユーザー名:


パスワード:





パスワード紛失  |新規登録

メインメニュー

更新ページ

ad
スポンサーリンク

投稿一覧

オンライン状況
12 人のユーザが現在オンラインです。 (1 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 12

もっと...